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Connection Reference

This document has reference information for managing a terminal’s
connections, including Microsoft Terminal Server (RDP) connections
and Citrix ICA connections.

Introduction to Connections
Terminals can connect to a Windows Terminal Server through LAN
connections and modem connections.

Two clients, each with its own communication protocol, provide
logical connections:

� RDP connections

The Microsoft Terminal Server client uses the RDP protocol to
connect to a Windows Terminal Server.

� Citrix ICA connections

The Citrix ICA client uses the ICA protocol to connect to a server
running Citrix WinFrame or to a Windows Terminal Server
running Citrix MetaFrame.

A third client, the NCD dial-up client, provides network transport
for an RDP or ICA session over a modem.

You create connections with connection wizards and administer
them with the Connection Manager.
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Introduction to Connections

The Connection Manager has a Connections tab for starting or
ending connection sessions and a Configure tab for configuring
connections:

By default, the Configure tab is enabled and configuring
connections is allowed. However, it is possible to protect the
configuration by disabling the tab, as described in NCD ThinSTAR
Terminal Properties Reference.

After you set the terminal up with the setup wizard, the connection
wizard for your default client starts so that you can define at least
one connection.
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RDP Connections

RDP Connections
The Microsoft Terminal Server client uses the RDP protocol. This
section explains how to add and use Microsoft RDP connections.

Adding and Configuring an RDP Connection
To add an RDP connection:

1. Start the WTS (Windows Terminal Server) connection wizard.

Note It starts after setup if the default client is Microsoft
Terminal Server. Later, you can press Ctrl+Alt+End to
display the Connection Manager, then select the
Configure tab, click Add, and select the Microsoft
Terminal Server client as the type.

2. Specify a connection name and server, then click Next.

— Name

The name of the connection, up to 32 characters. For example,
Lab 8 identifies a Terminal Server; dBase or Finance identify
an application.

— Server

The IP address or host name of the Terminal Server to host
the connection.

You can use a host name only if DNS or WINS is enabled,
and, for DNS, a default domain was defined through DHCP
or during setup.

If there is no default domain or the DNS server and the
terminal are in different TCP/IP domains, specify a fully
qualified domain name.

A dial-up connection may need the fully qualified domain
name or IP address, depending on your PPP service.

— Low Speed Connection

Select this if connecting to the server through a low
bandwidth WAN or serial line.
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RDP Connections

3. Enable or disable automatic user logon, then click Next.

By default, automatic user logon is disabled and users must
provide login data when using the connection. Leave this feature
disabled if automatic logon poses an unacceptable security risk.

To let a user log on automatically when starting this connection,
check Automatic Logon and provide logon information:

— Username

The user ID of a local user on a particular server or a global
user on a Domain Controller.

— Password

The password for the user ID; it is kept in encrypted form.

— Domain

The Windows NT domain name, if the server belongs to a
Windows NT domain and the Primary Domain Controller
authenticates users.

The name of the server if you want it to authenticate users or
if it is not a member of a Windows NT domain.
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RDP Connections

4. Choose what to display when the connection starts, then click
Next.

— Desktop

Display the Windows NT desktop.

— Application file name

Do not start with the Windows NT desktop. Instead, start an
application; when the user closes this application, the
connection ends.

Enter the directory path and file name of the application. Use
the full path if it is not specified in the user ’s environment on
the Terminal Server host.

— Working directory

If you specified an application, you can give the path to a
working directory. By default, the application saves data files
in that directory.

If you do not specify a working directory, the application
saves data files in the user ’s home directory on the host.

For Windows NT 4.0, the directory is set in
Start > Programs > Administrative Tools > User Manager
for Domains > User > Properties > Profile.

For Windows 2000, the directory is set in Start > Programs >
Administrative Tools > Computer Management.

5. Click Back to review or change previous settings, then return
and click Finish to apply the settings.

The Connection Manager includes the new connection in its list
of connections.

If you have just created the first connection and the terminal is in
dial-up mode, the NCD dial-up client’s connection wizard starts.
See Adding an NCD Dial-Up Connection on page 26.
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RDP Connections

Configuring an RDP Printer in Terminal Properties
When you set properties on the Management > Clients tab of
Terminal Properties, you can set some client properties globally. For
example, you can configure a printer for RDP connections.

To configure a printer for RDP connections:

1. In Terminal Properties, select Management > Clients.

2. Select Microsoft Terminal Server Client and click Configure.

3. Select a printer and click Properties.

4. Enter information:

— Friendly Name

Give a name users will recognize.

— Manufacturers

Select a manufacturer.

— Printers

Select a printer.

5. Choose whether to make the printer the default printer.

6. Click OK.
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RDP Connections

Starting an RDP Connection
You start connections from the Connection Manager, which lists all
connections on its Connections tab. You can press Ctrl+Alt+End to
display the Connection Manager.

A terminal must be in the correct mode—LAN or dial-up—to start a
connection. To change the mode, see the NCD ThinSTAR Terminal
Properties Reference.

To start an RDP connection:

1. In the Connection Manager, select the Connections tab, then
double click the name or select the name and click Connect.

If the connection was correctly defined, and the server is
running, the connection starts.

If the terminal cannot connect, select the Configure tab. Correct
the server specification for the connection if it is wrong, then try
to connect again.
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RDP Connections

If you have the right server, see whether it is running and check
whether the terminal is physically connected to the network. You
can use the Management > Network > Diagnostics tab in
Terminal Properties to do this. For information, see
NCD ThinSTAR Terminal Properties Reference.

2. Enter logon information—user name, password, and domain—if
requested, then click OK. A connection may require logging on
manually or the user information in an automatic logon
connection may be wrong or may not be authenticated for that
server. The connection starts the specified application or the
server ’s desktop, depending on startup options set in Step 4 on
page 5.

Stopping an RDP Connection
You can stop connections by logging off the Windows NT desktop or
suspend them by quitting the Windows application. A suspended
connection or application continues to uses server resources, so some
sites discourage disconnecting.

� Logging Off

On the Windows NT desktop, select Start > Logoff to close open
applications, then log off and end the connection.

� Disconnecting

On the Windows NT desktop, select Start > Disconnect to log off
and end the connection, but leave open applications running in a
suspended state. When you reconnect to the server, the
applications are in the same state as when you disconnected. It
may be convenient to disconnect, but applications left running
may place excessive demands on the server.
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ICA Connections
The Citrix ICA client provides both network and dial-in connections
using the ICA protocol. It does not support modem callback.

Adding an ICA Network Connection
A connection wizard asks for information necessary to create a
connection. The screens it displays vary somewhat depending on the
version and build of the Citrix ICA client. This section includes
screens for both the Citrix ICA client version 2.20, build 645, and the
Citrix ICA client version 2.20, build 727. Generally, build 645 is
installed on NCD ThinSTAR terminals and build 727 is installed on
later models. The screens for build 645 are to the left; those for 727
are to the right.

You can check the version in Terminal Properties. To go to Terminal
Properties from the Connection Manager, press F2. To check the
version, select Inventory > Software > Installed Software and find
Citrix ICA.

After adding the first connection, you can create additional
connections as needed. To do that, press Ctrl+Alt+End to display the
Connection Manager, then start the wizard from the Connection
Manager. To start the wizard, select the Configure tab and click Add.
Select the Citrix ICA client as the type of connection.

Adding an ICA Network Connection

To create an ICA network connection:

1. Start the connection wizard.

If the Citrix ICA client is the default client, its connection wizard
starts after you complete the setup wizard so that you can define
one connection.
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ICA Connections

2. Select Network Connection as the connection type and click
Next.

3. Select a server or published application and click Next.

The lists displayed depend on the global ICA client settings in
Terminal Properties, as described in Making Global ICA Client
Settings on page 17. By default, they include servers or published
applications in the local network.

The client uses the primary Citrix server to build the lists. To
build the first list, it does an auto-locate broadcast and uses the
first ICA server browser that responds. If servers or published
applications do not appear and you think they should, click
Refresh to update the lists. For example, you may need to refresh
the lists in the following situations:

— A server or published application does not appear because
the network had a temporary problem or a server was down.

— You have just added or deleted servers.

— You have just added a server on another subnet in one of the
server locations.

Addresses on Remote Networks

To list servers and published applications on remote networks,
click Server Location, edit the list, and click OK.

— Server Group

If your screen includes a Server Group option, you locate
available servers and published applications by group. This
selection is used instead of a group defined in global settings
for the Citrix ICA client in Terminal Properties.
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ICA Connections

You can define up to three groups of Citrix servers to which
you want to contact: a primary and two backups. The client
attempts to contact all the servers within the Primary group
using directed packets; the first server to respond is then
queried for the address of the master ICA Browser. If none of
the servers respond, the client attempts to contact all the
servers within the Backup 1 group. If there is still no
response, the client attempts to contact all of the servers in
the Backup 2 group. This process is repeated each time the
user attempts to make an ICA connection.

— Addresses

The default address, Auto-Locate, lists servers and published
applications on the local network only.

You can use the following buttons to edit the list:

4. Specify a title for the connection. For Citrix ICA build 645, this
information is requested in Step 9.

By default, the server or published application name is
displayed. To specify a different title, backspace through the
default name and type another name.

Add To include servers and published applications on
remote networks, such as those on the other side of
a gateway, click Add. Enter the name or IP address
of a server that tracks servers on the remote network
and click OK. ICA browsing is not supported in dial-
up mode.

Delete To delete a server from the list, select it and click
Delete.

Move Up/
Move Down

To reorder the list, use Move Up and Move Down.
The first server listed, the primary server, is
consulted first to build the list of servers and
published applications. The second server is
consulted next, and so on.

Default List The list saved last is the default list. To replace the
current list with the default list, click Default List,
then click Yes.
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ICA Connections

5. Choose what to display when the connection starts, then click
Next.

To start with the Windows desktop, leave this information blank.

To start with an application, enter the following information:

— Command Line

Enter the path and name of the application. During the
session, you can run only this application. When you quit the
application, the session ends.

— Working Directory

Enter the drive and path of the working directory (optional).

This associates the directory with the application; when you
access a file from the application, the application uses the
working directory by default. For example, commands in the
application’s File menu operate, by default, on files in the
working directory.

6. Specify logon information, then click Next.

If you enter a valid user name, password, and server domain, it
is used for an automatic logon.

If you leave any of these fields blank, the connection prompts for
all of the information.

For published applications, the logon information must be valid
for the server running the published application. If the
connection is to an anonymous published application, the logon
information is ignored.

7. Choose whether to use 16 colors or 256 colors for the desktop or
application, then click Next.

A dial-up connection may be faster with 16 colors.

The default number of colors displayed is affected by the global
ICA client settings you can make in Terminal Properties. For
more information, see Making Global ICA Client Settings on page
17.



NCD ThinSTAR Connection Reference 13

ICA Connections

8. Specify compression and sound, then click Next.

Provide information as follows:

— Compress Data Stream

Enable or disable data compression. Enabling compression
reduces the amount of data transferred between the terminal
and server but increase the load on the server.

Disabling compression reduces the load on the server but
transfers more data. With a high speed LAN, compression
may be unnecessary.

— Cache

Not supported in this release.

— Enable Sound

Allows applications to play sound on the terminal.

— Sound Quality

If sound is enabled, set sound quality. The higher the quality
level, the greater the bandwidth consumption.

Medium is recommended for LAN-based connections.

Low is recommended for low-bandwidth connections,
including modem connections.

— Encryption Level

Not supported in this release.

9. Specify a title for the connection. For Citrix ICA build 727, this
information is requested in Step 4.

By default, the server or published application name is
displayed. To specify a different title, backspace through the
default name and type another name.
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ICA Connections

10. If you have Citrix ICA build 727, enter firewall information.

If you are using a SOCKS proxy server to limit access to Citrix
servers, you must configure the ICA Client to connect to Citrix
servers through a SOCKS proxy server. You can configure a
default SOCKS proxy for all connections or use only a SOCKS
proxy with a specific connection file.

To configure a default SOCKS proxy server, select Connect via
SOCKS proxy and enter the SOCKS proxy server ’s IP address
and the proxy server ’s port number (if it is not 1080).

Note If you configure a default SOCKS proxy server, you can
successfully browse for a server or published application
only if you specify at least one server in Step 3.

If the terminal is outside a firewall that uses address remapping,
you must configure the ICA Client to use the alternate address
returned by the master ICA Browser. This is necessary even if
you are not using a SOCKS proxy server.

Note You must use the ALTADDR utility to manually set the
alternate address for each Citrix server. For information,
see the Command Reference appendix of your
MetaFrame Administrator ’s Guide or the WINFRAME
System Guide.

Note If you set alternate address translation for all connection
entries, it cannot be disabled for specific connection
entries.

11. Click Finish to save the connection, then click OK.
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ICA Connections

Adding an ICA Dial-In Connection
For a connection over a modem, you can add an ICA dial-in
connection.

This requires configuring the ICA dial-in server. See the WinFrame/
MetaFrame documentation for instructions.

The NCD dial-up client provides an alternative way of adding a
connection over a modem. To use this method, identify the ICA
connection as a network connection and set dial-up options as
described in Adding an NCD Dial-Up Connection on page 26.

To create an ICA dial-in connection:

1. Start the connection wizard.

If the Citrix ICA client is the default client, its connection wizard
starts after you set up the terminal so that you can define one
connection.

2. After adding the first connection, you can press Ctrl+Alt +End to
display the Connection Manager, then start the wizard from it.

To start the wizard, select the Configure tab, click Add. Select the
Citrix ICA client as the type of connection.

3. Select Dial-In Connection as the connection type and click Next.

4. Provide modem information as follows, then click Next.

— Dial-In Device

Modem type. Hayes Compatible is the only type supported.

— Area

The area code of the number to dial, for future use.

— Phone Number

The full phone number (long distance access, country code,
area code, and phone number), with or without hyphens.



16 NCD ThinSTAR Connection Reference

ICA Connections

— Country

For future use.

— Use Area and Country Codes

For future use.

Click Configure if you want to configure port settings and call
options (see Step 4 on page 28 for definitions), then click OK.

5. Complete the remaining screens. These screens are the same as
those for a network connection; explanations for completing
them begin with Step 4 on page 11.
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ICA Connections

Making Global ICA Client Settings
In Terminal Properties, you can define default settings for all ICA
client connections. You can override some of these settings when you
create an ICA connection.

To set global settings for the ICA client:

1. From the Connection Manager, press F2 to start Terminal
Properties.

2. Select Management > Clients.

3. Select the Citrix ICA client beside the Configure Client button,
then click the button.

4. Make global ICA client settings on any or all of the following
tabs, then click OK to save your changes or click X to cancel
them: Hotkeys, Preferences, Server Location, Firewall Settings
(only in Citrix ICA build 727).

Hotkeys

The Citrix ICA client provides hotkeys for basic functions. These
affect the ICA client or emulate standard Windows sequences.

Default Values for the ICA Client Hotkeys

Function Default Description

Status Ctrl+6 Displays the status of the connection.

Close
application

Ctrl+2 Disconnects the ICA client from the server and closes the
client window, but the session still runs on the server. To avoid
this, log off instead of using the hotkey.

Toggle title bar Ctrl+3 Hides or displays the window title bar.

Ctrl+Alt+Del Ctrl+4 Sends the standard Windows Ctrl+Alt+Del to the server.
Displays the Windows NT Security information.

Ctrl+Esc Ctrl+5 Sends the standard Windows Ctrl+Esc to the server. The
remote Task List appears on WinFrame servers; the Windows
NT Start menu appears on MetaFrame servers.
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ICA Connections

Preferences

Provide data as follows.

— Serial Number

Leave this empty.

— Default Window Colors

Check 16 or 256 colors. NCD ThinSTAR terminals use up to
256 colors. Low-bandwidth connections, such as most
modem connections, may perform better with 16 colors.

— Enable Palette Device

Always checked for Citrix ICA build 645. Not in later builds.

— Client Name

The terminal name used when a printer is attached to the
terminal during an ICA session. For details, see Configuring
ICA Access to Printers on page 23.

— Allow Automatic Client Updates

For future use.

Alt+Esc Ctrl+7 Sends the standard Windows Alt+Esc. Cycles through
minimized icons and open application windows.

Alt+Tab Ctrl+8 Sends the standard Windows Alt+Tab to the server. Cycles
through open applications, displaying programs.

Alt+Backtab Ctrtl+9 Cycles through open applications in reverse order.

Default Values for the ICA Client Hotkeys (continued)

Function Default Description
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Server Location

The ICA client uses this data to locate servers and published
applications when you create or edit an ICA connection.

— Server Group

If your screen has a Server Group option, a group you select
here is used instead of a group defined in global settings for
the Citrix ICA client in Terminal Properties.

You can define up to three groups of servers—one primary
and two backups. When an ICA connection starts, the client
tries to contact servers in the Primary group; if a server
responds, it asks for the address of the master ICA Browser. If
not, the client tries to contact the servers in Backup 1, and, if
necessary, the servers in Backup 2.

— Addresses

Auto-Locate, the default, causes the client to seek only
servers and published applications on the local network. You
can use the following buttons to edit the list:

— Rename Groups

You can change group names.

Add To include servers and published applications on a
remote network, click Add. Give the name or IP
address of a server that tracks servers on the remote
network and click OK. ICA browsing isn’t supported
for dial-up.

Delete To delete a server from the list, select it and click
Delete.

Move Up/
Move Down

To reorder the list, use Move Up and Move Down.
The first server listed, the primary server, is
consulted first to build the list of servers and
published applications. The second server is
consulted next, and so on.

Default List The list saved last is the default list. To replace the
current list with the default list, click Default List,
then click Yes.
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Firewall Settings

You can make global firewall settings.

If you are using a SOCKS proxy server to limit server access, you
must configure the ICA Client to connect to Citrix servers
through a SOCKS proxy server. You can configure a default
SOCKS proxy for all connections or use only a SOCKS proxy
with a specific connection file.

To configure a default SOCKS proxy server, select Connect via
SOCKS proxy and enter the SOCKS proxy server ’s IP address
and the proxy server ’s port number (if it is not 1080).

Note If you configure a default SOCKS proxy server, you can
successfully browse for a server or published application
only if you specify at least one server in Step 3.

If the terminal is outside a firewall that uses address remapping,
you must configure the ICA Client to use the alternate address
returned by the master ICA Browser. This is necessary even if
you are not using a SOCKS proxy server.

Note You must use the ALTADDR utility to manually set the
alternate address for each Citrix server. For information,
see the Command Reference appendix of your
MetaFrame Administrator ’s Guide or the WINFRAME
System Guide.

Note If you set alternate address translation for all connection
entries, it cannot be disabled for specific connection
entries.
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Starting an ICA Connection
You start connections from the Connection Manager, which lists all
connections on its Connections tab. If the Connection Manager is not
displayed, press Ctrl+Alt+End.

A terminal must be in the correct mode—LAN or dial-up—to start a
connection. To change the mode, see the NCD ThinSTAR Terminal
Properties Reference.

1. In the Connection Manager, select the Connections tab, then
double click the connection or select the connection and click
Connect.

If the connection was correctly defined and the server is running,
the connection starts.
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If the terminal cannot connect, select the Configure tab. Correct
the server specification for the connection if it is wrong, then try
to connect again. If you have the right server, see whether it is
running and check whether the terminal is physically connected
to the network. For more information, see the NCD ThinSTAR
Terminal Properties Reference.

2. Enter logon information—user name, password, and domain—if
requested, then click OK. A connection may need a manual
logon or the user information in an automatic logon connection
may be wrong or may not be authenticated for that server.

The connection starts the specified application or the server ’s
desktop, depending on startup options set when it was defined.

Stopping an ICA Connection
You can log off or disconnect ICA connections. Disconnecting
suspends the connection and leaves it executing on the server; you
can reconnect later and resume any tasks left running. Since the
connection continues to use server resources even if disconnected, it
may be better to log off.

Logging Off

On WinFrame servers, in the Program Manager, select File > Logoff,
then click OK to confirm.

On MetaFrame servers, select Start >Logoff.

Disconnecting

On WinFrame servers, in the Program Manager, select File >
Disconnect, then click OK to confirm.

On MetaFrame servers, select Start >Logoff.
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Configuring ICA Access to Printers
During a Citrix ICA session, a user can print to a printer attached to
the serial or parallel port of an NCD ThinSTAR terminal if the server
allows client printer mapping and the printer is mapped as
explained in the following sections.

It is possible to print to local printers during connections to servers
or published applications. In an application’s print command, the
user selects the local mapped printer from the list of printers.

To map a local printer, you must associate a client name to the
terminal. You can change the name on the Preferences tab of Global
ICA Client Settings. The default name is the terminal’s serial
number.

You must configure every Windows NT server needed for printing.
The details differ depending on the build version of the ICA client,
so use the instructions for the version you have. To check the version,
go to Terminal Properties, then select Inventory > Software >
Installed Software and locate the Citrix ICA entry.
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Configuring Printer Access in MetaFrame

The following sections have instructions for ICA client builds 727
and 645.

Instructions for ICA Client Build 727

To configure access to a local printer:

1. Log onto the Citrix server.

2. Click Start > Programs > MetaFrame Tools > ICA Client Printer
Configuration.

3. Printer > New.

4. Complete the wizard to map the client printer.

Instructions for ICA Client Build 645

To configure access to a local printer:

1. On the MetaFrame server, click Start.

2. Select Settings > Printers, then select a network printer.

Printers have names similar to clientname#port, where clientname
is the name you assigned through Global ICA Client Settings and
port is a port on the terminal, such as COM1 or LPT1.

If no client printer is available, add one.

— Double click the Add Printer icon in the Printers window
and complete the screens presented.

— Click Network printer server and double click Client.

— Select the printer and click OK.

— Terminal printer ports have names similar to clientname#port.

— If you want this printer to be the default printer, click Yes,
then click Next.

— Click Finish.
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Configuring Printer Access in WinFrame

The following sections have instructions for ICA client builds 727
and 645.

Instructions for ICA Client Build 727

To configure printing to a local printer when connected to the
WinFrame server:

1. Log onto the Citrix server.

2. Go to the Administrative Tools program group of the Program
Manager.

3. Double click ICA Client Printer Configuration.

4. Complete the wizard to map the client printer.

Instructions for ICA Client Build 645

To configure printing to a local printer when connected to the
WinFrame server:

1. On the WinFrame server, in the Main program group, double
click the Print Manager icon.

2. Select a network printer.

Note Printers have names similar to clientname#port, where
clientname is the name you assigned in the Global ICA
Client Settings and port is a port on the terminal; for
example, COM1 or LPT1.

If no client printer is available:

— From the Printer menu, click Connect to Printer.

— In the list of shared printers, double click Client Network.

— Double click the Client icon.

— Select the client printer icon, which has a name similar to
clientname#port, and click OK.

— If you want this printer to be the default printer, select it in
the Default menu.
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NCD Dial-Up Connections
The dial-up client provides a network connection over a modem.
Once the connection is established, a protocol client connection
(RDP, for example) can start. Therefore, you must configure both a
dial-up connection and a connection for an RDP client, ICA client, or
an optional installed protocol client.

After you complete the Setup Wizard, the terminal starts the
appropriate connection wizard (RDP or ICA) if no connection exists.
It then starts the NCD dial-up connection wizard.

Note The NCD dial-up client does not support modem callback.

If you want to connect to an ICA session over a modem you have
two choices:

� You can create an ICA dial-in connection as described in Adding
an ICA Dial-In Connection on page 15.

� You can create an NCD dial-up connection, then create an ICA
network connection to use over the dial-up line.

Adding an NCD Dial-Up Connection
This section explains how to create an NCD dial-up connection.

To add an NCD dial-up connection using the NCD dial-up client:

1. Start the connection wizard.

If you select the dial-up client as the default when configuring
the terminal, the dial-up connection wizard starts after you
create an RDP or ICA connection so you can configure the dial-
up connection.

If connections exist and you want to add more, go to the
Configure tab of the Connection Manager and click Add, then
select the NCD dial-up client.
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2. Specify the connection name and click Next.

The name could identify the host or the application. It can have
up to 20 characters when you are defining the connection. If you
edit the connection from the Connection Manager, the name can
be extended to 32 characters.

3. Select a modem.

Currently, only Hayes-compatible modems are supported.
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4. Click Configure to configure the port settings and call options
and click OK.

Provide information for Port Settings as follows.

— Manual Dial

If this is enabled, the user can enter data and modem
commands in a separate window when dialing. The manual
dialing window is provided by the Microsoft Windows RAS/
TAPI subsystem. If manual dialing is disabled, the NCD dial-
up client dials the phone number and no window is
displayed.

— Terminals

Use terminal window before dialing

If this is enabled, the user can enter modem commands
before dialing the host computer.

Use terminal window after dialing

If this is enabled, the user can enter commands to the host
computer after dialing is complete.
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— Connection Preferences

Choose values as follows.

The following serial port parameters (baud rate, data bits,
parity, and stop bits) determine the characteristics of the
connection between the terminal and the modem and are
automatically sensed by the modem. The modem uses these
parameters to define the format of the data that it sends to the
host and expects from the host.

Baud Rate—Determines the upper limit of the speed of the
connection between the modem and the host. Select the
highest speed available on the terminal’s modem; the modem
does not negotiate a connection higher than the baud rate
you specify.

Data Bits—The number of data bits generated by the
terminal and expected by the host.

Parity—The type of parity generated by the terminal and
expected by the host.

Stop Bits—The number of stop bits generated by the
terminal and expected by the host.

Flow Control—The type of flow control handshaking used
on the terminal’s serial port and expected by the host. You
can select one of the following:

If you choose Hardware, hardware handshaking, also called
DTR/DSR, is used.

If you choose Software, the terminal sends an XOFF (^S)
character when the input buffer space is low and an XON
(^Q) character when input buffer space is available. This is
not recommended because noise on the line can introduce
spurious XOFF characters than can cause the connection to
freeze.

If you choose None, there is no flow control handshaking.



30 NCD ThinSTAR Connection Reference

NCD Dial-Up Connections

Provide information for Call Options as follows.

— Call Setup

Use these options as follows.

Cancel the call if not connected within seconds—This option
cancels the call if it is not completed within the specified
time. Set this to the amount of time you are willing to wait for
the connection to occur.

Wait for dial tone before dialing—When this is enabled, the
call does not go through until there is a dial tone. Disable this
if you are making a direct serial connection between two
modems and not using the phone line. With such a
connection, there is never a dial tone.

Wait for credit card tone seconds—This option waits for the
specified time before continuing the call to allow time for
entering a credit card number.

— Extra Settings

You can enter modem commands here to override the default
settings; for example, to turn on local echo, enter ‘E1’.
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5. Click TCP/IP Settings to configure TCP/IP, then click OK.

Supply information on the General tab as follows:

— Server-assigned address

Select this item if your dial-in host supplies the terminal with
an IP address. Uncheck this box and fill in the IP address field
if the host does not supply an IP address. You may want to
assign an address (if allowed by the server) for long-term,
dedicated dial-up connections.

— Use SLIP

Enable this option if the dial-up server does not support the
default protocol, PPP.

— Use software compression

Compression speeds up data transmission; however, it can
only be used if the terminal and the host use compatible
compression methods. It should not be necessary to disable
this option.

— Use IP header compression

Compression speeds up data transmission; however, it can
only be used if the terminal and the host use compatible
compression methods. It should not be necessary to disable
this option.
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Supply information on the Name Servers tab as follows:

— Server-assigned addresses

Causes the dial-up client to accept from the dial-in server the
IP addresses of the hosts providing name service.

Select this option if your dial-in host gives the terminal name
resolution parameters. Disable this option and enter the DNS
and/or WINS name server host addresses if the PPP host
does not give name server information or if you want to use
different name server hosts.

— Primary and Secondary DNS

The IP address of the first DNS server to resolve device
names and the IP address of the DNS server to resolve device
names if the primary server cannot.

— Primary and Secondary WINS

The IP address of the first WINS server to resolve device
names and the IP address of the WINS server to resolve
device names routed if the primary server cannot.

6. Click Next.
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7. Specify the telephone number to dial and click Next.

Type the complete phone number of the modem on the dial-in
server; using up to 128 characters. For example:

9-1-650-555-1212

Note Hyphens are not required. Remove them, if necessary, to
remain within the 128-character limit.
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Selecting a Startup Session for an NCD Dial-Up Connection
A connection can start automatically once the dial-up network
connection is established. The list shows your protocol connections
(RDP or ICA). If no protocol session is selected, selection occurs after
the dial-up connection is started from the Connection Manager.

To specify the protocol connection to start and other options:

1. Select a protocol connection or <none>.

2. To automatically close the dial-up connection when the user logs
off or disconnects from the protocol session, enable Close dial-
up connection at session end. Otherwise, the dial-up connection
remains open and the user can select another protocol session.

3. To erase the saved user name and password, click Forget
Password.

When the connection is first created, this option is not available.
The user can enable it by saving the user name and password
after starting the connection. For more information about saving
the user name and password, see Starting an NCD Dial-Up
Connection on page 35. Depending on your environment, saving
the password may be an unacceptable security risk.

4. Click Next.

5. To review or change settings, click Back. To apply the settings,
click Finish. The new connection is included in the list of
connections in the Connection Manager.
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Starting an NCD Dial-Up Connection
The terminal must be in dial-up mode as described in the
NCD ThinSTAR Terminal Properties Reference.

To start a dial-up connection, using the NCD dial-up client:

1. Press Ctrl+Alt+End to display the Connection Manager.

2. On the Connections tab of the Connection Manager, double click
the connection name or select the connection and click Connect.

If the connection was correctly defined, and the server is
running, the connection starts.

If the terminal cannot connect, select the Configure tab. Correct
the dialing specification for the connection if it is wrong, then try
to connect again.

3. The first time you use a dial-up connection, you must log in. You
can click Save Password if you do not want to enter it the next
time you start the connection.

Note If saving the password introduces an unacceptable
security risk, you can edit the dial-up connection and
enable Forget Password. See Selecting a Startup Session for
an NCD Dial-Up Connection on page 34 for more
information.

4. Begin a protocol connection session.

If a startup session is defined for the connection, it starts
automatically.

If none is defined, press Ctrl+Alt+End to display the Connection
Manager, select a protocol connection, and click Connect.

5. Enter logon information—user name, password, and domain—if
requested, then click OK.

A connection may require logging on manually or the user
information in an automatic logon connection may be wrong or
may not be authenticated for that server.

The connection starts the specified application or the server ’s
desktop, depending on startup options.



36 NCD ThinSTAR Connection Reference

NCD Dial-Up Connections

Stopping an NCD Dial-Up Connection
How you stop the dial-up connection depends on how it is
configured.

Configuration Setup How you stop

Close dial-up connection
at session end is enabled.

Log off or disconnect from the application host. The
connection stops automatically, then the dial-up
session ends.

Close dial-up connection at
session end is disabled or
no startup session was
selected.

Log off or disconnect from the application host, then
click Disconnect to stop the dial-up connection when
prompted.

You can also highlight the active dial-up session in the
Connection Manager and click End.
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Managing Connections
The Configure tab of the Connection Manager has options for
performing the following functions:

� Adding connections

� Editing connections

� Deleting connections

� Stopping connections

� Setting a connection as the default or setting it to start
automatically

The Connection Manager is on the terminal screen when no
connection is running. To display it when a connection is running,
press Ctrl+Alt+End.

By default, the Configure tab is displayed, making it easy to set up
connections on a terminal. After you have created connections, you
can hide the Configure tab to preserve the connections. Instructions
are in the NCD ThinSTAR Terminal Properties Reference.

Adding a Connection in the Connection Manager
After you have created one connection as part of the startup process,
you can use the Connection Manager to create new connections.
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To add connections:

1. On the Configure tab of the Connection Manager, click Add.

2. Select the type of connection, then click OK. The list includes
optional clients that you have installed.

3. If the client software provides a wizard or utility for defining a
new connection (most do), it starts now.

For the Microsoft Terminal Server client, see page 3. For the
Citrix ICA client, see page 9. For an NCD dial-up client, see page
26.
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Editing a Connection in the Connection Manager
To modify the properties of a connection:

1. On the Configure tab of the Connection Manager, select the
desired connection.

2. Click Edit and make changes.

Edit mode and the connection wizard may present properties
differently. For example, properties for an RDP connection
appear as follows:

Client information is on the following pages: Microsoft Terminal
Server on page 3; Citrix ICA on page 9; NCD dial-up on page 26.
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Deleting a Connection in the Connection Manager
To delete an existing connection:

1. On the Configure tab of the Connection Manager, select the
connection you want to delete.

2. Click Delete and confirm that you want to delete the connection.

Stopping a Connection from the Connection Manager
It is best to disconnect or log off from the host desktop or
application, but you can also stop a connection from the Connection
Manager.

Note To disconnect or log off, see Stopping an RDP Connection on
page 8, Stopping an ICA Connection on page 22, or Stopping an
NCD Dial-Up Connection on page 36.

1. Select the Connections tab of the Connection Manager.

2. Select the active connection and click End, then click OK when
prompted to confirm that you want to disconnect.

If you do not respond or have a problem with the session, click
End Task when prompted to terminate immediately.

A connections that is
running has active
status.

The End button
disconnects (suspends)
connections, but leaves
them running on the
server, using resources.
For this reason,
administrators often
prefer to have users log
off.
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Setting Startup Options in the Connection Manager
You can select one connection as the default connection or as an
autostart connection.

Setting a Default Connection

The default connection is the one highlighted when you display the
Connection Manager.You can start the default connection, or switch
to it, by pressing Ctrl+Alt+Home. One connection can be the default
connection. If you set a connection as an autostart connection, it
automatically becomes the default.

To set a connection as the default:

1. On the Configure tab of the Connection Manager, select the
connection you want to have as the default and click Startup.

2. Select Make the selected connection your default connection
and click OK.
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Setting an Autostart Connection

You can configure a connection to start automatically when you
restart the terminal.

When you log off, the autostart connection restarts immediately. If
this happens and you want to stop it, see page 43.

A dial-up connection must specify a protocol connection as well for
true automated startup, or it is necessary to start the protocol
connection manually at logon.

Configuring a connection to start automatically makes it the default
connection. If you later make another connection the default, the
original autostart connection no longer starts automatically.

To configure a connection to start automatically:

1. On the Configure tab of the Connection Manager, select the
connection you want to start automatically.

2. Click Startup, then select Automatically start the selected
connection at startup and click OK.
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The autostart connection fails unless it corresponds to the
terminal’s network connection mode—LAN or dial-up. If you
need to change the mode, see the NCD ThinSTAR Terminal
Properties Reference.

Stopping an Autostart Connection

An autostart connection restarts as soon as you close the
Windows NT desktop or log off. To prevent this, set the connection
as the default connection rather than the autostart connection.

To stop the autostart connection:

1. While the autostart connection is active, press Ctrl+Alt+End to
go to the Connection Manager.

2. Select the Configure tab.

3. Click Startup.

4. Select Make the selected connection your default connection
and click OK.

5. To return to your running connection, select the Connections tab
and select the active connection.

6. Click Connect.
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