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NCD ThinPATH Manager Reference

This document has reference information for the following 
NCD ThinPATH tools for system administrators:

■ The Configuration Tool lets you define terminal properties and 
connections for groups of terminals or specific terminals and 
distribute the values from a central location.

■ The Web Configuration Tool lets you use a web browser to set 
properties for a specific terminal from any location.

■ The Remote Restart Tool lets you restart terminals from a central 
location. When the terminals restart, they get the new 
configuration values.
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ThinPATH Configuration Tool

ThinPATH Configuration Tool 
To use this tool, select Start > Programs > Administrative Tools 
(Common) > NCD ThinPATH Manager > NCD ThinPATH 
Configuration Tool.

The application has two panes, or frames. The left pane shows a 
subclass list in a tree view to simplify the process of configuring 
groups of terminals. With the NCD ThinPATH Configuration Tool, 
you can define configuration values for groups of terminals or 
individual terminals in the left pane.

The right pane is similar to the Terminal Properties provided on the 
NCD ThinSTAR terminals.

This tool shows the same allowable settings in the same locations as 
in Terminal Properties. Parameters that cannot be set globally, such 
as a static IP address, however, are not included in the NCD 
ThinPATH Configuration Tool. Other parameters are available only 
through the NCD ThinPATH Configuration Tool. These are describ-
ed in Relationship to NCD ThinSTAR Terminal Properties on page 6.
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ThinPATH Configuration Tool

With the Configuration Tool, you can:

■ Set up groups or individual subclasses of terminals.

■ Configure terminal property settings for a subclass of terminals.

■ Save settings in a configuration file on the Management Server.

■ Register the configuration file so that terminals with NCD 
ThinSTAR Operating SSoftware version 2.0 or later can receive 
the file when they restart.

■ Configure terminal identification properties.

■ Choose how much, if any, of the NCD ThinSTAR Configuration 
Setup Wizard appears when a terminal starts at setup. 

You can modify and resave a configuration file at any time; the 
terminals receive it when they restart. Or, you can create and register 
a new configuration file. The latest registered configuration file 
always goes to the terminals.

The configuration file should contain terminal property settings only 
for the parameters you want to change. There is no need to define 
and save settings for parameters that have acceptable default values.

What’s a Subclass?
A subclass consists of one or more terminals. By assigning terminals 
to a subclass, you can apply the same terminal property settings to 
all the terminals in that subclass.

You can configure any terminal property on a global or subclass 
basis. You may want some settings to apply globally and other 
settings to apply to a group of terminals. With the NCD ThinPATH 
Configuration Tool, you can set up subclasses as needed.
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ThinPATH Configuration Tool

Subclass List Tree Control
The top branch of the tree in the left pane has the name of the 
configuration file prepended to Global Settings. In the example 
shown on the previous page, it is Wabash.tcf Global Settings.

The named items (except Global Settings) that display when the tree 
is expanded specify custom configuration settings for a subset of 
terminals, beyond the global configuration settings for all terminals. 
You define or modify terminal groups or individual terminal 
subclasses using an editor dialog, which is accessed using either the 
Subclass menu commands or by right-clicking (left-clicking on a left-
handed mouse) a tree control item to open the context menu.

You can use the tree control to:

■ Create new subclasses

■ Select a subclass to configure

■ Edit subclasses

— Reconfigure subclasses

— Add or remove subclass members

■ Remove subclasses

Subclass Order
A terminal can be a member of more than one subclass, with 
different terminal property settings in the subclasses. The 
Configuration Tool handles this situation by applying settings 
according to the order of the subclasses in the subclass list. The lower 
its position in the subclass list, the higher the subclass ranks in 
precedence. Subclasses at the bottom of the subclass list have highest 
precedence, so the terminal property setting in the subclass closest to 
the bottom of the list is assigned to the terminal.

Global settings located at the top of the subclass list have the lowest 
precedence of all. When a terminal property has a global setting and 
a different setting for the same item in a subclass, the Configuration 
Tool assigns the subclass setting to the terminals in that subclass.
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ThinPATH Configuration Tool

Changing the Order of Subclasses

To assign one subclass precedence over another, move the subclass 
beneath in the subclass list. As stated earlier, the nearer a class is to 
the bottom of the list, the higher its precedence.

To move a subclass, do one of the following:

■ Click on the name of the subclass you want to move, hold the 
mouse button down, and drag it to another position in the 
subclass list.

■ Right-click (left-click on a left-handed mouse) on the subclass 
name to open the context menu, and then use the Move Up or 
Move Down commands to change the position of the subclass.

Note You cannot change the position of Global Settings in the 
subclass list.

Properties
The right pane of the Main Window contains properties organized 
by labeled tabs. You can assign settings to the selected subclass 
highlighted in the subclass list.

Asterisk in Tab Labels

The asterisk at the end of a tab label, such as Display*, means that 
values on the tab have been set or changed, but are not yet saved.
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ThinPATH Configuration Tool

Relationship to NCD ThinSTAR Terminal Properties
Some controls in the Configuration Tool are not provided in 
Terminal Properties on NCD ThinSTAR terminals or are provided in 
a different manner.

Include Checkbox

Most top level tabs have an Include checkbox for including or 
removing all the settings on that tab from a configuration. 

In addition, some tabs have checkboxes you can use to include or 
exclude the individual settings in the configuration file. When 
excluded, the corresponding control for changing a setting (if any) is 
not accessible, so it is not available in the dialog.

Default Button

The Default button, located in the lower right corner of all applicable 
tabs, lets you return the included parameters to their default 
Terminal Properties settings.

Network Tab

You cannot use the Configuration Tool to specify terminal IP addresses.

Security Tab

The Security > Change Password tab lets you replace the current 
Terminal Properties password or set a new one if none exists. 
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ThinPATH Configuration Tool

You can use the Security > Terminal Properties Access tab of the 
Configuration Tool to allow or disallow user changes to Terminal 
Properties on the terminal. The settings for tabs you configure to be 
read-only are not available to be changed in Terminal Properties.

The Terminal Properties Enable tab, also on the Security tab, allows 
you to disable the F2 key command that launches Terminal 
Properties on NCD ThinSTAR terminals.

Hotkeys Tab

The Management > Hotkeys tab is used to set the Up and Down 
hotkey combinations that are used to bring forward the next active 
or previous active session. You can also set the Home hotkey 
combination that brings forward or starts the default connection.

Power Tab

The Management > Power tab provides a control for setting the 
System Soft Off Timeout wait period. This timer governs the 
terminal (not the monitor) power saving mode on ThinSTAR 300 and 
400 series terminals. ThinSTAR 200 and 250 terminals do not have 
the power saving mode.

Clients Tab

The Management > Clients tab contains the same parameters that are 
available in Terminal Properties, but they are arranged differently. 
You use the settings on this tab to configure global client properties 
for clients that allow it, set the default client, set the terminal locale, 
and disable access to the NCD ThinSTAR Connection Manager 
Configure tab.

Note The Microsoft Terminal Server client does not support client 
configuration so they are not shown in the list of client names 
on the Management > Clients > Configure tab. Only clients 
that support client configuration are listed.
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ThinPATH Configuration Tool

SNMP Tab

The Management > SNMP tab of the Configuration Tool is used to 
configure settings for the Simple Network Management Protocol 
(SNMP). SNMP, another method for configuring terminals remotely, 
is an agent in the NCD ThinSTAR Operating Software. By default, 
SNMP only allows you to view terminal settings—it shows the 
settings on a read-only basis.

The SNMP settings you make become a part of the configuration file. 
When the Management Server downloads this configuration file to a 
terminal, the SNMP agent on the terminal can be reconfigured to 
allow SNMP writes from the specified SNMP manager.

You can also configure the SNMP agent on the terminal to send a 
message known as a “trap” to the SNMP manager on the server 
when the terminal restarts or when an attempt to change terminal 
property settings fails on the terminal. Traps for these occurrences 
are available on the Management > SNMP > Send Traps tab:

■ Cold Restart

This trap instructs the SNMP agent on the terminal to send a 
message to the SNMP manager on the server when a terminal 
restarts. This notifies the system administrator that someone has 
restarted the terminal.

■ Authentication Failure

This trap instructs the SNMP agent on the terminal to send a 
message to the SNMP manager on the server when an 
authentication attempt fails. This notifies the system 
administrator that someone who does not have administrative 
privileges may be trying to change terminal property settings.

System Tab

The Management > System tab lets you set the startup state of the 
Num Lock, Caps Lock, and Scroll Lock keys on the keyboard. You 
can set up Num Lock, for example, to be on automatically each time 
the terminal starts up. 
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ThinPATH Configuration Tool

Extensions Tab

This tab provides a way to skip some or all of the terminal setup 
wizard pages. 

Connections Tab

The Connections tab is for:

■ Setting up connections

■ Limiting the number of connections that run on the terminal

■ Removing connections

The Connections > Configure tab provides connection wizards 
similar to those found on the terminal for adding connections for 
installed clients, such as RDP and ICA.

Note Client libraries can be added in the future to support 
configuration of new types of connections.
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ThinPATH Configuration Tool

Configuration Files
The Configuration Tool stores terminal property settings in a 
configuration file. If the configuration file has been registered with 
NCD ThinSTAR Management Server, the NCD ThinSTAR terminals 
receive it when they restart. The terminals must have NCD 
ThinSTAR Operating Software version 2.0 or later. During restarts, 
each ThinSTAR terminal checks the configuration file, reads the file 
if it is new, and applies the settings intended for that terminal.

Use the configuration file to change the default settings of your 
terminals. It is not necessary to store settings for parameters if you 
want to leave them at their default settings.

After launching the Configuration Tool, you have these options:

■ New Configuration Settings

The Configuration Tool starts with an empty configuration as a 
new, untitled file. By default, all the tabs, and thus all settings, 
are excluded.

■ Open Configuration Settings

The tool presents a File Open dialog that lets you browse to find 
the configuration file you want to open.

■ Open Registered Configuration

If a configuration file is registered with the Management Server, 
you use this option to open it. 

Registered Configuration Files
A registered configuration is the file the Management Server 
downloads to the ThinSTAR terminals it manages when they restart. 
The utility program that downloads the file is called TMS.

The Configuration Tool provides three ways to register a 
configuration file:

■ TMS > Register Current Configuration command

■ TMS > Register Configuration command 

■ File > Save As command
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ThinPATH Configuration Tool

After you set and save selected terminal settings in a configuration 
file, use one of these methods to register the file:

■ Use the TMS > Register Current Configuration command to 
register the currently open configuration file. If you have not 
saved the current configuration yet, the Save Configuration As 
dialog appears so you can specify a filename.

.

■ Use the TMS > Register Configuration command. This is like the 
Register Current Configuration command, but you can select any 
saved configuration file.

■ Use the File > Save As command. When the Save Configuration 
As dialog appears, click the checkbox beside “Register this 
Configuration with TMS” and supply a filename.

Note When you register a configuration file, any previous regis-
tration is cancelled. Only one file can be registered at a time.
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ThinPATH Configuration Tool

Cancelling Registration

As long as a configuration file is registered, any terminal supported 
by the Management Server is updated, as needed, when the terminal 
restarts. You may want to cancel registration, so that no file is 
available for the terminals. 

For example, you might want to do this if the terminals are 
configured, or if you are experimenting with terminal property 
settings. To cancel registration, select TMS > Remove Registration.
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ThinPATH Configuration Tool

Configuring Subclasses
This section tells how to use the Configuration Tool to set up, 
modify, and remove individual and group subclasses.

Individual Subclasses and Group Subclasses

You can set up a subclass for a single terminal or for a group of 
terminals. An individual subclass contains only one terminal and its 
icon shows one small terminal. A group subclass contains more than 
one terminal and its icon shows two small terminals.

There are a few differences between individual subclasses and group 
subclasses. For example:

■ When you set up a group subclass, you need to specify a list of IP 
addresses, hardware addresses, or serial numbers for the 
terminals you want to assign as members of the subclass.

■ The name of a group subclass can be any unique name. The name 
does not affect the list of terminals that receive the parameter 
settings stored in the configuration file for that group subclass. 

■ The name of an individual subclass indicates the terminal that 
receives the configuration, so the naming rules for an individual 
subclass are the same as they are for the individual members of a 
group subclass. Individual subclasses are named by IP address, 
hardware address or serial number.

IP Address Format

A standard IP address is represented by four decimal values 
separated by dots (dotted decimal format). The Configuration Tool 
also accepts IP address ranges. In an IP ranges, the numbers in the 
first three octets must be the same; only the numbers in the fourth 
and last octet (the Class C subnet) can be different. For example, 
192.45.85.6 is a member of the range indicated by 192.45.85.1 through 
192.45.85.10. 

If dynamic IP addresses are assigned by DHCP, you won’t know 
which terminal receives a given configuration file. If you are using 
DHCP, group terminals by their hardware address or serial number.
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ThinPATH Configuration Tool

Hardware Address Format

This is a standard Media Address Control (MAC) or hardware 
address. It is sometimes called a network address. The format of this 
address is:

xx:xx:xx:xx:xx:xx 

where x represents a hex digit 0–9, A–F 

For example: 00:00:A3:08:12:7C

This address is on the terminal. To see it, go to Terminal Properties 
and select Inventory > Network Settings > Address.

You can also specify a hardware address range, similar to an IP 
address range. In a hardware address range, you can vary only the 
values in the last three fields (the last six values).

Serial Number Format

This is the serial number assigned to an NCD ThinSTAR terminal at 
the factory. To find the serial number for a terminal, go to NCD 
ThinSTAR Terminal Properties and select Inventory > Hardware.

Note Once the ThinSTAR operating software version 2.0 or later 
has been downloaded to a terminal, the Management Server 
collects and updates the IP address, hardware address, and 
serial number from the terminal. This information is then 
available so that you can identify terminals for remote 
restarts. See Managing a Terminal List on page 19.

Individual Subclasses

Creating a New Individual Subclass

To create (add) a new individual subclass:

1. Select Subclass > New.

2. In the Subclass Name field, enter the IP address, hardware 
address, or serial number of the NCD ThinSTAR terminal you 
want to configure.
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Note You can enter only one of the three identifiers: 
IP address, hardware address, or serial number. If you are 
using dynamic IP addresses assigned by DHCP, it is 
better to identify the terminal by its hardware address or 
serial number.

3. Click the Individual Subclass radio button.

4. Select After Current Subclass or Before Current Subclass to 
indicate where to place the new subclass in the subclass list.

5. Click OK to add the new subclass to the list.

6. With the individual subclass highlighted in the subclass list, 
configure the terminal.

7. Select File > Save to save the changes in your configuration file.

Editing an Individual Subclass

To edit an individual subclass:

1. In the subclass list, click the name of the subclass to edit.

2. Select Subclass > Edit (or double-click on the name of the 
subclass).

3. To change the name of the subclass, make the change in the name 
field.

4. To change the subclass from an individual subclass to a group 
subclass, click the Group Subclass radio button. You can then 
edit it as a group subclass (see Editing a Group Subclass on page 
16 for instructions).

5. Click OK.

Removing an Individual Subclass

This procedure deletes the subclass and its tab settings when you 
save the configuration file.

To remove an individual subclass:

1. Click the name of the subclass to highlight it.
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2. Select Subclass > Delete, or press the Delete key.

3. Click Yes if you are sure you want to delete this subclass. 

The subclass is deleted when you save the configuration file.

Group Subclasses

Creating a New Group Subclass

To create a new group subclass:

1. Select Subclass > New.

2. Enter a name for the new subclass in the field provided. You can 
enter any unique name.

3. Set the type to Group Subclass (the default).

4. Select After Current Subclass or Before Current Subclass to 
indicate where to place the new subclass in the list.

5. Click OK.

Note You can specify a list of terminals as subclass members. 
Editing a Group Subclass on page 16 explains how to 
assign terminals to a new or existing group subclass.

6. Click OK when you are done assigning terminals to the group. 

7. With the group subclass highlighted in the subclass list, 
configure the terminal settings for the group.

8. Select File > Save to save the changes in the configuration file.

Editing a Group Subclass

Editing a group subclass involves adding or removing terminals 
from it as explained in the next two procedures.

To add terminals to a group subclass:

Note If the Edit Subclass dialog is already open from setting up a 
new group subclass, skip steps 1 and 2.

1. Click the name of the subclass in the subclass list to highlight it.
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2. Select Subclass > Edit, or double-click on the name of a subclass.

3. Click Add to assign subclass members (terminals) to the sub-
class, then use either or both of these methods to add members:

— Select members from the Managed Terminal List (discussed 
in Managing a Terminal List on page 19 and shown in the 
Select Members frame) and indicate whether to add them 
according to their IP address, hardware address, or serial 
number. You can use the Ctrl or Shift key or drag the mouse 
to select multiple members.

— Enter the IP address, hardware address, or serial number of a 
new member in the top field of the Enter Member frame. To 
enter a range of IP addresses or hardware addresses, enter 
the first terminal’s address in the top field and the last 
member’s address in the Through Address field.

4. If your subclass members contain consecutive ranges of IP 
addresses, hardware addresses or serial numbers, click the 
Expanded List checkbox on the Edit Subclass dialog to toggle 
between an expanded list that shows all members and a concise 
list that shows only the member range(s). Click OK to add the 
members.

5. When you finish assigning members to the subclass, click OK.

You cannot use serial numbers to specify a range.

For IP ranges, the numbers in the first three octets have to be 
the same; only the numbers in the last octet can be different, 
for example: 125.211.31.209 – 125.211.31.214

The Through Address must be greater than the first address.

If you are using dynamic IP addresses assigned by DHCP, it 
is better to group terminals by their hardware address or 
serial number.

You can also specify a hardware address range, varying only 
the values in the last three fields.
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Removing Subclass Members

This procedure deletes the subclass member or members when the 
configuration file is saved.

To remove subclass members from a group subclass:

1. Highlight the name of the subclass in the subclass list.

2. Select Subclass > Edit (or double-click on the name of the 
subclass) and the Edit Subclass dialog appears.

3. Highlight the subclass member to remove. You can use the Ctrl 
or Shift key or drag the mouse to make multiple selections.

You can click on a member in an expanded list to remove just 
that member or click on a range in a collapsed list and delete all 
the members in that range at once.

4. Click Remove.

5. Save the configuration file if you are sure you want to delete the 
subclass member(s).

Importing Members into a Subclass

The Configuration Tool lets you import members from a text file into 
a subclass. This capability allows you to import a large list of 
terminals that may have been exported from another piece of 
software, such as a database or a UNIX /etc/hosts file.

A column of data is delimited by space characters, tab characters, 
commas or semicolons in the file. Each member to add must be in the 
same column and on separate lines in the file.

To import members into a subclass:

1. Select the group subclass to which you want to import members.

2. Select Subclass > Import Members.

3. Locate the file containing the terminals to import and click OK.
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4. Select import options.

— Select the method used to store data in the file.

— If each row contains a single terminal name, select Each 
row is entirely the terminal identifier.

— If the terminal name is part of other information on each 
line of the file, select Fields are delimited within each row.

— Make additional selections to filter the data.

5. Click OK to import the terminal list.

Removing a Group Subclass

This procedure deletes the subclass along with its tab settings when 
the configuration file is saved.

To remove a group subclass:

1. Click on the name of the subclass to remove.

2. Select Subclass > Delete, or press the Delete key.

3. Click Yes if you are sure you want to delete the subclass.

Managing a Terminal List
To help you create groups of terminals on your network, the 
Management Server records IP addresses, hardware addresses and 
serial numbers for all terminals it manages. This list is known as the 
Managed Terminals List. The Management Server updates entries in 
the list if a terminal’s IP address changes, but it cannot detect 
terminals that have left the network. If a terminal leaves the network, 
it remains in the Managed Terminals List. You can use the NCD 
ThinPATH Remote Restart Tool to remove terminals from the list.

The Remote Restart Tool uses the list to select terminals to restart.

To view the list of managed terminals:

1. Select Utilities > Remote Restart Tool.

2. To view the properties of an individual terminal, right click on it 
and select Properties. 
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3. To delete one or more terminals from the list, select Edit > Delete 
Terminal, select the terminals to be deleted, and then OK.

Note Only delete terminal entries for devices no longer on the 
network. If you remove entries for terminals still 
managed by the Management Server, the terminals are 
added to the list the next time they start.

4. Close the Remote Restart Tool dialog.

The values in the Status field (Trying Restart, Restarting, Restart 
Pending, Not Responding, Wake-on-LAN, and Detected Terminal) 
are explained in Restart Status Values on page 35.

Terminals Do Not Receive Configuration Settings

If a terminal you configure with the Configuration Tool does not 
receive the parameter settings, there is no message to inform you. To 
troubleshoot the situation:

1. Ensure that the terminal has ThinSTAR Operating Software 
version 2.0 or later. To see which version is installed, go to the 
Inventory > About tab in Terminal Properties. You can check this 
using the Web Configuration Tool or at the terminal itself.

2. Check to see if the Configuration Tool subclass containing the 
terminal accurately reflects the terminal’s IP address, MAC 
address, or serial number.

3. Check to see if the terminal and Management Server are on 
different subnets. If so, the terminal’s entry on the 
Management > Server tab in Terminal Properties must list the IP 
address of the Management Server.

4. Verify that the configuration file registered by the Configuration 
Tool is the correct file.

To check this, open the registered configuration file; the name of 
the file appears in the title bar.

To register another configuration file, go to the TMS > Register 
Configuration or the TMS > Register Current Configuration menu.
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5. Check to see if the configuration file has recently been saved. 
Terminals will ignore configuration files with the same data and 
time stamp as previously received.

6. Check to see if you are using a network with a spanning tree 
switch. If so, you may need to increase the Management Server 
Timeout. The default is five seconds. Go to the Management > 
Network > Timeouts tab in Terminal Properties on the terminal 
to change this setting. For more information, see the NCD 
ThinSTAR Terminal Properties Reference.
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ThinPATH Web Configuration Tool
With a compatible web browser or the NCD ThinPATH Manager 
Remote Restart Tool, you can use the ThinPATH Web Configuration 
Tool to view and set most, but not all, of the terminal properties of a 
ThinSTAR terminal from any location. Netscape 4.0 and Microsoft 
Internet Explorer 4.0 are compatible browsers.

Installing the ThinPATH Web Configuration Tool on Terminals
Before you can configure an NCD ThinSTAR terminal with a web 
browser, you need to upgrade the terminal with the ThinPATH Web 
Configuration Tool as explained in the next topic. After the tool is 
installed on the terminal, you need the terminal’s IP address and 
password. If password protection has not been set up on the 
terminal, the terminal property settings are displayed in “Read 
Only” mode so you cannot change any terminal property settings. If 
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the terminal has password protection set up and you enter the 
correct password, you can use the ThinPATH Web Configuration 
Tool to reconfigure the terminal. Configuring Terminal Properties on 
page 24 provides a general procedure for using this tool.

By default, the ThinPATH Web Configuration Tool is not installed on 
terminals, due to the size of this software component. To install it, 
change the upgrade policy setting for this tool in TMS.

To install the ThinPATH Web Configuration Tool on terminals:

1. Start the ThinSTAR Manager (TMS) by selecting Start > 
Settings > Control Panel > ThinSTAR Manager.

2. Select the terminal type from the Select Terminal Model drop-
down list box.

3. Select NCD ThinPATH Web Configuration on the Software list 
and choose the “Upgrade if newer” policy.

4. Restart the ThinSTAR terminal.

5. Immediately after the terminal receives the ThinPATH Web 
Configuration Tool software, you can use this tool over the web 
to reconfigure the terminal.

Note This procedure assumes that password protection for the 
terminal is set up, and that you have the correct password. If 
password protection is not set up on the terminal, the 
terminal property settings are displayed in “Read Only” 
mode so you cannot change any terminal property settings. If 
the terminal has password protection set up and you enter 
the correct password, you can use the ThinPATH Web 
Configuration Tool to reconfigure the terminal. 
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Configuring Terminal Properties
To configure terminal properties with a web browser:

1. Start your web browser. 

Note Use Netscape 4.0 or later, Internet Explorer 4.0 or later, or 
the NCD ThinPATH Manager Remote Restart Tool.

2. Perform one of the following steps.

— Enter the URL of the NCD ThinSTAR terminal to configure in 
the Location or Address entry area of the web browser and 
press Enter (Return). For example, if the IP address of a 
terminal is 172.31.0.12, its URL would be http://172.31.0.12. 
(Most browsers automatically convert the IP address to the 
correct URL.)

Or

— From the ThinPATH Remote Restart Tool, select Tools > Web 
Configure. Click the terminal to configure and then OK.

3. When connected to a terminal that has password protection, 
your web browser displays the Web Configuration Login screen. 
Enter the password, and the General Configuration (main) page 
displays with the buttons for all pages available.

When connected to a terminal that does not have password 
protection, the General Configuration page displays, but “Read 
Only” appears at the bottom of the window. It is not possible to 
modify terminal property settings.

4. Click the appropriate button in the left frame to open the 
configuration page containing the parameters you want to view 
or set. For example, click Network to open the Network 
Configuration page to modify a Subnet Mask or Gateway. The 
configuration pages resemble those in Terminal Properties.

Note Clicking the Defaults button on the General Configur-
ation page brings up a dialog to confirm that you want to 
restart the terminal. If you confirm the restart, open 
connections will be terminated and unsaved work in 
open applications might be lost.
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5. Modify the settings and click Apply. The new settings are sent to 
the terminal. For most terminal properties, changes to settings 
take effect immediately, but changes to network settings, detailed 
in Restarting a Terminal Over the Web on page 27, don’t take 
effect until after the terminal restarts.

Note If you restart the terminal immediately, open connections 
and unsaved work in open applications may be lost.

6. Click Restart Terminal if you want to restart the terminal 
immediately.

Note If the terminal is in a group managed by a server with 
different settings, the web configuration settings will be 
overwritten when the terminal restarts. 

Setting Audio Over the Web: An Example

Here’s an example that shows how to use the ThinPATH Web 
Configuration Tool with a web browser to set terminal property 
settings over the web.

This figure shows the ThinPATH Web Configuration Tool > 
Management > Audio web page provided for setting speaker 
volume and muting speakers. (On ThinSTAR 300 terminals, you can 
also enable a microphone.)

To set speaker volume: 

1. If it is not already running, start your web browser.

Note Use Netscape 4.0 or later or Internet Explorer 4.0 or later.

2. Enter the URL for the ThinSTAR terminal, for example:

http://172.31.0.12

3. Enter the password for the terminal.

4. When the General Configuration page is displayed in your web 
browser, click the Management button in the left frame.

5. Click the Audio button in the top frame to display the audio 
settings panel.
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6. Enter a number in the range 0–100 for the speaker volume or 
click the Mute checkbox to disable the speakers.

7. Click the Enable checkbox if you want to enable a microphone on 
the terminal.

8. Click Apply. The new audio setting(s) are sent to the terminal.
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Restarting a Terminal Over the Web
For most terminal properties, you do not need to restart terminals 
after changing a setting because the change occurs immediately. 
Changes to terminal properties related to network settings, however, 
don’t take effect until after the terminal restarts. These include:

■ IP address

■ Subnet mask

■ Gateway

■ Settings on the Advanced Network page

To restart the terminal so that changes to these properties take effect:

1. If it is not already running, start your web browser.

2. Enter the URL for the ThinSTAR terminal, for example:

http://172.31.0.12

3. Click Restart Terminal.

4. Close the web browser.

Password Protection
Password protection prevents unauthorized terminal reconfigur-
ation. If a password has been set on the terminal and you enter it 
correctly, you can reconfigure the terminal. As stated earlier, most 
changes you make to the terminal properties take place immediately 
but some changes don’t take effect until you restart the terminal.

The ThinPATH Web Configuration Tool allows you to change an 
existing password over the web. If a terminal does not have 
password protection, you’ll need to use the ThinPATH 
Configuration Tool or Terminal Properties on the terminal to set the 
password on the Security tab.
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ThinPATH Remote Restart Tool
The ThinPATH Remote Restart Tool gives system administrators the 
ability to restart terminals from the Windows NT server.

To use this tool, select Start > Programs > Administrative Tools 
(Common) > NCD ThinPATH Manager > NCD ThinPATH Remote 
Restart Tool.

You can also access this tool from the ThinPATH Manager Configur-
ation Tool menu by selecting Utilities > Remote Restart Tool.

Restarting Terminals
To restart terminals:

1. Start the NCD ThinPATH Remote Restart tool.

2. Select Tools > Schedule Restart. The Restart Terminals… dialog 
displays. The list shows terminals running ThinSTAR operating 
software version 2.0 or later that have contacted TMS. To remove 
terminals from the list, see Managing a Terminal List on page 19.

3. Select one or more terminals to restart by clicking on the selection 
box in the left column. A check mark appears in the box when it 
is selected. Then, click OK. 
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4. Select one of the four restart types described below.

— Restart Immediate. This option restarts terminals 
immediately, regardless of open connections. Work in 
progress may be lost depending on whether your Windows 
Terminal Server resets or disconnects broken connections. 

There are two settings on a Windows Terminal Server for 
broken or timed-out connections: Disconnect and Reset (on 
Windows NT Terminal Server Edition) and Disconnect and 
End (on Windows 2000). 

To configure a Windows Terminal Server so terminals can 
reconnect to open applications after terminal restarts, go to 
the Advanced Connection Settings tab in Start > Programs > 
Administrative Tools > Terminals Server Connection 
Configuration, and select the Disconnect option.

To configure Windows 2000 so terminals can reconnect to 
open applications after a terminal restarts, go to Start > 
Programs > Administrative Tools > Terminal Services 
Configuration. Double-click Connections in the left pane, and 
double-click RDP-tcp in the right pane. On the Sessions tab, 
choose Disconnect from session or End session.

With the Disconnect option, when a terminal restarts during 
a session, the session goes into a disconnect state. When the 
terminal session restarts, suspended applications reopen. 

Note If you use the Reset (NT) or End (Windows 2000) 
options, any unsaved work is lost when the terminal 
resets and the session ends. Disconnect is the default 
configuration.

— Restart Pending. This option restarts terminals automatically 
after the last connection on the terminal is closed.

— Wake on LAN. If a terminal does not respond to a restart 
command, this option sends the terminal a Wake on LAN 
signal, which will turn on and start terminals that have the 
ability to receive such signals. This feature is not supported 
on ThinSTAR 200 or 250 series terminals.



30 NCD ThinPATH Manager Reference

ThinPATH Remote Restart Tool

— Detect. This option pings the selected terminals and updates 
the Status column of the ThinPATH Remote Restart Tool 
dialog to show the current status of the selected terminals. 
Restart Status Values on page 35 explains the values in the 
Status column.

5. Set the delay for the restart command. The delay is the number of 
seconds that elapse between restart commands sent to multiple 
terminals. This option is useful when many terminals are 
restarted at one time; it prevents overloading the ThinSTAR 
Management Server. Select a number from the drop-down list in 
the Delay (seconds) field.

6. Determine whether or not a report should be generated, and if 
so, select the Generate Report option. If a report is to be created, 
specify a filename and directory to contain the report. 

7. Click OK to restart the terminals. The Restarting Terminals... 
dialog displays. The Status column is updated to show the latest 
status of the terminals.

8. Check the Status column of the Restarting Terminals dialog to 
see the current status of each terminal. Restart Status Values on 
page 35 explains the values in the Status column.

9. Click Close to dismiss the dialog.
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Finding a Terminal
To find a terminal in the Managed ThinSTAR terminals list:

1. If it is not already running, start the NCD ThinPATH Manager 
Remote Restart Tool.

2. Select Find Terminal... from the Tools menu. In a moment, the 
Find Terminal dialog displays.

3. Enter search criteria into the field. You can search by terminal 
name, IP address, hardware address, or serial number. Select the 
Match Case option to find only those terminals that match the 
both the criteria and case you entered

4. Select the radio button corresponding to the search criteria you 
entered: Name, IP Address, Hardware Address, or Serial.

5. In the Start from: field, enter the name of a group of terminals. To 

see the names of groups that can be selected, press 

6. To extend the search beyond the selected group, select the Look 
in following groups option. A check mark appears in the box 
when this option is selected. Selecting this option tells the 
program to search for the specified terminal in the selected 
group, then in groups following it on the list, then in the 
terminals that are not assigned to a group.
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Scheduling a Restart
1. Start the NCD ThinPATH Remote Restart tool.

2. Select Tools > Schedule Restart. The Restart Terminals… dialog 
displays.

3. Select one or more terminals to restart by clicking the checkbox in 
the left column. A check mark appears in the box when it is 
selected. Then, click OK. The Schedule Restart Options dialog 
displays.

4. Under Scheduling Pattern, select one of two options:

— Run Once. Select this option to schedule a restart that occurs 
only once at a scheduled time.

— Recurrence. Select this option to schedule a restart that 
reoccurs on a periodic basis.

5. Next, select a time for the restart to take place. Time is shown in 
12-hour format. You can enter a time in the At: field either by 
using the keyboard, or using the arrow buttons on the right side 
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of the field to display a new time. The steps that follow are the 
ones to use if you are using the keyboard to enter a new time.

— Click on the pair of digits representing the hour. Enter a new 
hour setting.

— Click on the pair of digits representing the minutes. Enter a 
new minute setting.

— Click on the AM (or PM) element. Enter a new value (either 
PM or AM).

6. If the Scheduling Pattern selected is Recurrence, you also need to 
define how often the restart should occur. The following two 
options are available only when Recurrence is the selected 
scheduling pattern. 

— Daily. Select this option to repeat the restart every day at the 
selected time.

— Weekly on: Select this option to repeat the restart weekly on 
selected day(s), and then select the days of the week. You can 
select more than one day of the week. A check mark appears 
in the box in front of the day's name when it is selected. 

The remaining options on this screen are the same as those used to 
restart a remote terminal immediately. 

7. Select the appropriate restart action from the Restart Type drop-
down list. Using Restart Immediate may cause loss of open 
connections and unsaved work on the terminal.

Note Using Restart Immediate may cause loss of open 
connections and unsaved work on the terminal.

8. Determine whether or not a report should be generated, and if 
so, select the Generate Report option. If one is to be created, 
specify a filename and directory to contain the report. 

9. Click OK to restart the terminals. The Restarting Terminals... 
dialog displays. The Status column is updated to show the latest 
status of the terminals.

10. Click Close to dismiss the dialog.
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Viewing the Restart Schedule
Once terminals have been scheduled to restart, it is often useful to 
view the restart schedule. 

To view the terminals scheduled to be restarted, select Tools > Show 
Scheduled Restart....

If there are terminals scheduled to be restarted, the Restart Schedule 
Viewer dialog displays. 

If there are no terminals currently scheduled to restart, then selecting 
the Show Scheduled Restart… command has no effect.

To cancel a scheduled restart, select the terminal, then click Delete.



NCD ThinPATH Manager Reference 35

ThinPATH Remote Restart Tool

Restart Status Values
The Status column of the ThinPATH Remote Restart Tool dialog 
shows the response of each terminal in the list to restart command. 
This table explains the values in the Status column.

Status Value Meaning

Trying Restart A restart command has been sent to the 
terminal. The software is attempting to restart 
the terminal. This value appears momentarily.

Restarting The terminal is currently restarting. This status 
only appears when the terminal receives a 
restart command from the Remote Restart 
Tool—it does not appear when a terminal is 
physically restarted.

Restart Pending The terminal has received a restart command 
that instructs it to delay restarting until all 
terminal connections are closed, rather than an 
immediate restart command.

Not Responding The terminal did not respond to the restart 
command. This status value displays after the 
restart command times out. More on the 
Restart Command on page 36 explains why 
terminals do not restart.

Wake-on-LAN The terminal received a Wake-on-LAN 
command and the Remote Restart Tool is 
waiting for the terminal to power up.

Detected Terminal The terminal responded to a Detect (ping) 
request.
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More on the Restart Command

Terminals that are powered on respond to the restart command in 
one of two ways, depending on the type of restart that was selected:

■ They restart immediately.

■ They delay restarting until their last connection closes.

ThinSTAR 200 and 250 terminals that do not restart when 
commanded are assigned the status of “Not Responding” in the 
terminal list after the command times out. This probably indicates 
that the terminal is not powered on. 

ThinSTAR 300 and 400 terminals that do not restart on command are 
sent a Wake-on-LAN command. ThinSTAR 300 and 400 terminals 
that were turned off using the front power switch receive the 
command and “wake” or power up and restart. If a ThinSTAR 300 or 
400 terminal does not respond to a Wake-on-LAN command, the 
power switch on the back of the terminal is probably in the Off 
position, so a remote restart is not possible and the terminal’s status 
remains “Wake-on-LAN.”
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ThinPATH Manager Installation Errors
The following error and status messages may occur during 
installation of NCD ThinPATH Manager.

NCD ThinPATH Manager Installation Errors 

Error Description/Recommended Response

You must be logged in as a 
system administrator on this 
computer before you can 
run this program.

You need system administrator privileges. Log on to the 
Windows NT server as an administrator.

ThinSTAR Management 
Service not found. This 
application must be run on a 
server that has the 
ThinSTAR Management 
Service installed.

TMS is required.

If TMS is not installed on your Windows NT server, install it 
when you install NCD ThinPATH Manager.

To run the NCD ThinPATH Remote Restart Tool, you must 
install SNMP Services.

The error message appears after you enter the license key 
if the Microsoft Windows SNMP Network Service is not 
installed on your system.

To run the NCD ThinPATH 
Remote Restart Tool, you 
must install SNMP servers.

The ThinPATH Remote Restart Tool needs the Microsoft 
Windows SNMP Service.

If SNMP service is not installed, select Start > Settings > 
Control Panel > Network > Services and click Add. 
Select SNMP Service from the list. You may need to use 
the original Windows NT operating system CD to complete 
the installation.

SNMP parameters are unnecessary and the actual SNMP 
service can be stopped, since it is the .dll files that are 
necessary.
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ThinPATH Configuration Tool Errors
The following error messages may appear.

NCD ThinPATH Manager Configuration Tool Errors

Error Description/Recommended Response

You must be logged in as a 
system administrator on this 
computer before you can 
run this program.

You lack system administrator privileges.

Log on to the Windows NT server as an administrator.

ThinSTAR Management Service not found. This application 
must be run on a server that has the ThinSTAR 
Management Service installed.

ThinSTAR Management 
Service not found. This 
application must be run on a 
server that has the 
ThinSTAR Management 
Service installed.

TMS is required.

If TMS is not installed on your Windows NT server, install it 
when you install NCD ThinPATH Manager.

Could not find a valid 
ThinPATH license. Exiting.

No valid license key has been found.

This error may also occur if you have been using an 
evaluation copy of the NCD ThinPATH Manager software 
that has expired.

Run the License Manager and enter the correct license 
key(s) that came with NCD ThinPATH Manager. The license 
key is on the back of the license card in the package.

Invalid Server IP Address, 
The Manager name must be 
an IP Address [or similar 
message]

You entered an invalid IP address. 

Enter the correct IP address.

Invalid Subclass Name. The 
name must be an IP 
Address, a Hardware 
Address, or a Serial Number.

You entered an invalid subclass name.

Enter the correct IP address, hardware address, or serial 
number.
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ThinPATH Web Configuration Tool Errors
The following error messages may appear.

A Group Subclass must 
contain at least one 
member. You can choose to 
Import Subclass Members 
from a text file or you can 
convert the Group Subclass 
to an Individual Subclass 
and continue.

You clicked OK before assigning at least one member to a 
new group subclass.

Assign one or more members to the group subclass.

Password validation error: 
the passwords entered do 
not match.

The password you entered as the New Password is not 
identical to the password you entered at Confirm Password.

Set a new password.

NCD ThinPATH Web Configuration Error Messages

Error Description/Recommended Response

Value of audio_volume 
should be between 0 and 
100 [or similar message]

A setting is out-of-range.

Enter a valid value.

Invalid Server IP Address, 
The Manager name must be 
an IP Address [or similar 
message]

You entered an invalid IP address. 

Enter the correct IP address.

Password validation error: 
the passwords entered do 
not match.

The password you entered as the New Password is not 
identical to the password you entered at Confirm Password.

Set a new password.

NCD ThinPATH Manager Configuration Tool Errors (continued)

Error Description/Recommended Response
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ThinPATH Remote Restart Tool Errors
The following error messages may appear.

NCD ThinPATH Remote Restart Errors

Error Description/Recommended Response

You must have administrator 
privileges to run this 
program.

Administrator privileges are required. Log on as an 
administrator.

The NCD ThinSTAR 
Management Service must 
be installed in order to run 
this program.

TMS is required.

If TMS is not installed on your Windows NT server, install it 
when you install NCD ThinPATH Manager.

Warning: The SNMP network 
service must be installed in 
order to restart terminals.

SNMP Network Service is not installed.

Install the Microsoft Windows SNMP Network Service on 
your system. To do this, select Start > Settings > Control 
Panel > Network > Services and click Add. Select SNMP 
Service from the list. You may need to use the Windows NT 
operating system CD to complete the installation.
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Glossary

 

browser Software for locating, displaying, and interacting with sites 
on the World Wide Web. Netscape 4.0 and Internet Explorer 
4.0 have been tested and found to work satisfactorily with the 
ThinPATH Web Configuration Tool.

client A client is a program that depends to some extent on the 
services of another program or system. In ThinPATH 
Manager, a client is a network protocol used to make terminal 
connections (for example, Microsoft Terminal Server Client).

connection A method for starting a session on a network server.

DHCP Dynamic Host Configuration Protocol. A program that 
assigns dynamic IP addresses.

hardware address An Ethernet address or Media Address Control (MAC) 
address.

IP address The Internet Protocol (IP) address identifies a module on a 
network using TCP/IP.

remote 
configuration

The process of changing terminal property settings for one or 
more terminals from a server or computer at another location.

SNMP Simple Network Management Protocol. Included in the NCD 
ThinSTAR Management software. An SNMP agent is another 
method for setting terminals remotely. It provides a way to set 
some parameters that are not configurable through other 
ThinSTAR terminal interfaces.
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SNMP trap An SNMP trap directs an SNMP agent running on a terminal 
to send a message to the server running the SNMP manager 
to inform the system administrator that a cold restart or 
authentication failure has occurred on the terminal.
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